FrontPage II: Page Editing

Center for Teaching, Learning, and Technology

Phone: 410.337.6066
E-mail: training@goucher.edu
Web: www.goucher.edu/training

Revised March 2005
Table of Contents

Special Notations and Symbols ........................................................................................................ iii

Chapter One: New Pages And Text .......................................................................................... 1
  Opening A Page ..................................................................................................................... 2
  Creating New Pages .......................................................................................................... 3
    • Blank Pages .............................................................................................................. 3
    • From A Template ..................................................................................................... 3
  Working With Text ............................................................................................................. 4
    • Paragraph And Line Breaks ..................................................................................... 4
    • Formatting Toolbar .................................................................................................. 5
  Creating Links ...................................................................................................................... Error! Bookmark not defined.
  Saving Pages ..................................................................................................................... 10
  Previewing Web Pages ...................................................................................................... 11
    Training Exercise #1 ................................................................................................. 12

Chapter Two: Page Settings ...................................................................................................... 13
  Changing The Page Background ....................................................................................... 14
  Tables .................................................................................................................................. 15
    • Table Layouts ......................................................................................................... 15
    • Inserting A New Table ........................................................................................... 16
    • Navigating Inside A Table ..................................................................................... 16
    • Sub-Title ................................................................................................................. 17
  Publishing To The Internet ................................................................................................ 19
    • Selecting Pages To Publish .................................................................................... 22
    Training Exercise #2 .................................................................................................... Error! Bookmark not defined.

Chapter Three: Even More Stuff .............................................................................................. 24
  Inserting A Horizontal Line ............................................................................................... 25
  Inserting Images ............................................................................................................... 26
  Editing Images .................................................................................................................. 28
    Exercise: Chapter Three ............................................................................................. Error! Bookmark not defined.
# Special Notations and Symbols

<table>
<thead>
<tr>
<th>Notation</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Keystroke</td>
<td>📡Enter</td>
<td>Press Enter on the keyboard</td>
</tr>
<tr>
<td>Button/Mouse</td>
<td>OK</td>
<td>Click on OK in the current window</td>
</tr>
<tr>
<td>Menu Item</td>
<td>Tools, Options</td>
<td>Go to the Tools menu and select Options.</td>
</tr>
</tbody>
</table>

## Notation | Graphic
--- | ---
Time Saving Shortcut | 🕒
Hot Tip! | 🌶️
Caution! | 🚨
Chapter One: New Pages And Text

In this chapter, learn how to …

- Open files for editing
- Use built-in page templates to create pages
- Add and format text
- Save pages
- Customize page backgrounds
- Apply text formatting
Opening A Page

You can open any page to edit it by **double-clicking** on it. A tab for each page that is currently open will appear next to the *Web Site* panel tab.

The *index.htm* page is being editing in this example. The asterisks (*) shows it has not yet been saved.

Once a page is open, you can use the view buttons at the bottom of the panel to change how the page is displayed.

<table>
<thead>
<tr>
<th>View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal</td>
<td>Allows you to do most of your page editing as if you were using a word processor.</td>
</tr>
<tr>
<td>Split</td>
<td>Splits the editing area into two parts: Design and Code.</td>
</tr>
<tr>
<td>Code</td>
<td>Displays the HTML code for users to view or edit.</td>
</tr>
<tr>
<td>Preview</td>
<td>Shows users how the page would look and function if viewed in an Internet Explorer browser window.</td>
</tr>
</tbody>
</table>
Creating New Pages

Blank Pages

To add a blank page to your web site, use the **NEW** button on the toolbar.

From A Template

You also have the option to use one of the many page templates included with FrontPage.

**STEPS**

1. From the **File** menu, select **New**.
2. The New Page task pane will appear on the right. Click on the “More page templates…” link.
3. Double-click on the desired template from the list displayed.
Working With Text

Working in a web editor is almost like working in a word processor. However, there are some differences due to the HTML environment.

**Paragraph And Line Breaks**

One of the first things you’ll notice as you add your text is that pressing `Enter` on the keyboard creates a double space. This is known as a **paragraph break**.

To single space between lines, use `Shift + Enter` on the keyboard. This will create a **line break**.

<table>
<thead>
<tr>
<th>CAUTION!</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you use line breaks and then try to apply paragraph formatting to just one line of text, the formatting will apply to all the lines in that paragraph. Paragraph formatting includes such things as alignment, bullets, line spacing, etc...</td>
</tr>
</tbody>
</table>
**Formatting Toolbar**

Below is a table outlining some of the options available on the formatting toolbar.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal</td>
<td>Applies a style, which is a set of formatting options (including font, size, alignment, etc.), to the selected text. Changes the font of the selected text. If you choose default font, then the font will be determined by the individual browser settings.</td>
</tr>
<tr>
<td>Palatino Linotype</td>
<td>The third button from the left changes the point size of the selected text.</td>
</tr>
<tr>
<td>12</td>
<td>Makes the selected text appear as bold, italic, or underlined.</td>
</tr>
<tr>
<td><img src="image" alt="Bold, Italic, Underline" /></td>
<td>Makes the selected text aligned with the left margin, aligned with right margin, or centered between the left and right.</td>
</tr>
<tr>
<td><img src="image" alt="List" /></td>
<td>Creates a numbered list. In HTML, this is called an ordered list.</td>
</tr>
<tr>
<td><img src="image" alt="List" /></td>
<td>Creates a bulleted list. In HTML, this is called an unordered list.</td>
</tr>
<tr>
<td><img src="image" alt="Indent Decrease" /></td>
<td>Decreases the indentation of the selected paragraph.</td>
</tr>
<tr>
<td><img src="image" alt="Indent Increase" /></td>
<td>Increases the indentation of the selected paragraph.</td>
</tr>
<tr>
<td><img src="image" alt="Highlight" /></td>
<td>Changes the background color of the selected text. This is called highlighting the text.</td>
</tr>
<tr>
<td><img src="image" alt="Color" /></td>
<td>Changes the color of the selected text. Use the drop-down ▼ to display a color palette to choose from.</td>
</tr>
<tr>
<td>CAUTION!</td>
<td>Keep it simple! Unless a font is specifically installed on the user’s PC, the browser will convert the font to its “best guess”. Fancy or unusual fonts usually do not get displayed, often with disastrous consequences.</td>
</tr>
</tbody>
</table>
Creating Links

Links are simply pointers that tell the browser to display another set of information on the screen. Links can point to other locations on the same page, to a different web page on the same site, or to an entirely different web site all together. They can also be used to download a file, play a sound file, run a video file, or create an e-mail message. (This class will focus on navigational links.)

Using Bookmarks

Bookmarks are special locations in a web page that you would like to access quickly with a hyperlink. If a web page has distinct topics or sections, you could create bookmarks to those specific locations and create a list at the top of the page that contains links to them.

STEPS

1. Place the cursor in front of the text to be targeted or select the first part of targeted information
2. Click on the Insert menu and select Bookmark.
3. Enter a name for the bookmark. If you selected your text first, a name will already appear in the box.
4. Click on OK.

If you selected the text of the bookmark, it will be designated with a dotted underline. Bookmarks created without selecting text first will have a “flag” symbol displayed where the bookmark has been inserted. These symbols only appear in the FrontPage editing window and will not appear when viewing the page from a browser.
Creating Links

**STEPS**

1. Type in the text that you would like to use as a trigger for the link (the underlined blue text) and select it.

2. Based on the type of link that you are creating, do one of the following:

   - **Another Page (on your site):**
     
     Select the page from the list already displayed in the window. If it is not displayed, double click on the folder name that contains the file.

     If the document that you are providing a link to is not one that can be viewed by the user’s browser (like a Word or Excel file), it will prompt the user to open it or save it to disk.

   - **Bookmark:**
     
     Click on the drop-down next to Bookmark and select one from the list.

   - **E-mail Address:**
     
     Click on the envelope type in an e-mail address, and then click on Ok.

   - **URL:**
     
     Click in the URL box and type in the address to the website of the link. Make sure that you include the http:// portion of the address.
When finished, click on **OK**.
Saving Pages

Saving your work in FrontPage is similar to saving files using other Microsoft products. Simply use the SAVE button on the toolbar. However, there are some important tips to remember when saving pages in FrontPage:

- Switching to another view does not save your work.

- If you’ve added graphics to your pages that have not been manually imported into your site, you will be prompted to save them separately, as part of your web, when you save the page.

- It is recommended that you avoid including spaces in a file’s name. If you do, the user may receive an error message like... “Page Not Found”.

- Make sure you include the .htm extension for your web pages.

- Pay attention to the Title of your page when you save. The Title is displayed at the top of the browser window when users access your page on the Internet. If it needs to be changed, click on the CHANGE button in the Save As window.
Previewing Web Pages

In order to view your web page like someone who is accessing it over the Internet, it is a good idea to preview it using more than one browser.

You can accomplish this by saving the web page that you want to view and then selecting **Preview in Browser** from the **File** menu. Choose the browser that you would like to use from the list of those installed on your computer.
Training Exercise #1

Test your understanding of the concepts covered in Lesson One by completing the following exercise:

1. Open the “department” web located in your class files under /FrontPage Classes/Page Editing Fundamentals/. (Opening webs is covered in the FrontPage I training session.)

2. Open the index.htm page (page 2). This is a blank page that you will be modifying.

3. Using the Heading I style (page 5), create a title that displays the name of your department and then add a brief introductory paragraph about your department with any formatting you want. Add a few paragraph breaks at the end of your text (page 4).

4. Add your contact information to the bottom of the page and include your e-mail address as a link (page 8).

5. Add a few more paragraph breaks, then the text “Information For Visitors”. Convert this text to a link to the visitors.htm page located in the visitors folder (page 8).

6. Finally, add the text “Goucher Home” to the bottom of the page and convert this text to a link to Goucher’s main page (page 8). Save and close the page.

7. Create a new blank page (page 3).

8. Add the text “Department Goals” to the top of the page and a bulleted list of a few of your department’s current goals. Close and save the page as goals.htm with an appropriate title (page 10).

9. Open the visitors.htm page (located in the visitors folder of the web) and create links from each of the locations listed to the corresponding page in the visitors folder of the department web (pages 2 and 8).

10. Save and close the page (page 10).
Chapter Two: Page Settings

In this chapter, learn how to …

- Change the background color
- Use a table layout
- Modify tables
- Publish pages to the internet
- Complete a training exercise
Changing The Page Background

Web pages are not limited to just black-and-white text as with most printed material. Use the steps below to change the background of your page to a different color, or even to a picture or repeating pattern.

STEPS

1. Open the desired page.
2. Choose **Background** from the **Format** menu.
3. Choose the desired settings (see below) and click on **OK**.

![Page Properties dialog box]

- Check for picture background. Use BROWSE button to specify picture.
- Use dropdown to choose a solid color.
Tables

Tables in a web page can do more for you than neatly line up numbers in columns and rows. Tables are often used instead of tabs to precisely lay out the text and graphics on your page.

Table Layouts

An efficient way to create a specific “look” to your pages is to apply one of the built-in table layouts included with FrontPage. These layouts are available from the “Layout Tables And Cells” task pane. If this task pane isn’t visible, you can easily display it:

**STEPS**

1. If there is currently no task pane displayed on the right side of the screen, go to the **View** menu and select **Task Pane**.

2. If necessary, change the task pane to **Layout Tables And Cells** by using the drop-down arrow next to the pane title.

3. To apply a table layout, click on the layout desired at the bottom of the task pane.

A table with the chosen layout will be inserted into the current page. Click inside any cell to begin adding text or graphics where desired.
**Inserting A New Table**

**STEPS**

1. Place the insertion point where the table should begin.
2. Click on the **INSERT TABLE** button on the toolbar.
   
   A grid will appear below the toolbar button. Move the mouse pointer over the grid until the correct number of columns and rows are highlighted, and then click.

   A table with the selected amount of columns and rows will be inserted into the page at the insertion point.

**Navigating Inside A Table**

<table>
<thead>
<tr>
<th>Keyboard Keys</th>
<th>Position In the Table</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab</td>
<td>Next cell to the right</td>
</tr>
<tr>
<td>Shift + Tab</td>
<td>Previous cell to the left</td>
</tr>
<tr>
<td></td>
<td>Next cell in that direction</td>
</tr>
<tr>
<td>← Enter</td>
<td>Starts a new paragraph in the cell</td>
</tr>
</tbody>
</table>
Editing Tables

You have several options for adjusting the look of your table. Changes can be made with the mouse, the Table menu or by right-clicking.

Selecting Columns/Rows

**STEPS**

1. Move the mouse just above the top border of the desired column or the left border of the desired row. The cursor will become a dark arrow pointing down toward the column or pointing right toward the row.
2. Click once to select a single column, or click and drag across the table to select multiple columns.

| Hot Tip! | You can also use a menu instead of the mouse. Put your cursor in the correct column or row, and then select the Table menu and Select Column or Select Row. |

Inserting or Deleting Columns/Rows

Once the column or row has been selected, right-click in the highlighted area to choose Delete or Insert as desired.

| Time Saver! | If you press the ⌘ key from the last cell in your table, a new row is inserted automatically. |
**Splitting or Merging Cells**

When you split a cell, a single cell becomes two cells. When you merge several cells, they all become one.

**STEPS**

1. Select the cell or cells in question.
2. Right-click in the highlighted area.
3. Choose **Split Cells** or **Merge Cells** as desired.

**Changing Column Width/Row Height**

**STEPS**

1. Move the mouse over the vertical (or horizontal) line separating one column (or row) from another and the mouse will turn into a double-headed arrow. 
2. Click and drag the line to the desired position and let go.

**Hot Tip!**

The most comprehensive way to make changes to your table is to edit either the Table properties or the Cell properties. Either option is available when you right click on a cell.
Publishing To The Internet

Publishing is the term used in FrontPage for transferring copies of your finished pages from your PC to your account on MEYERHOFF (or any other web server) in order for it to be accessible from the Internet.

You must have a FrontPage web folder assigned to you on MEYERHOFF in order to complete this step. To request a web folder, contact the Help Desk by phone at x6322 or by e-mail at helpdesk@goucher.edu.

STEPS

1. If you’ve been editing different pages in your web, make sure you’ve saved all of your changes.

2. Click on the PUBLISH button on the toolbar
3. Type in the name of the URL where the new pages are to be stored.

Start with http:// and use the table below to determine the remaining URL for web sites on MEYERHOFF

<table>
<thead>
<tr>
<th>Status</th>
<th>URL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Students</td>
<td><a href="http://students.goucher.edu/username">http://students.goucher.edu/username</a></td>
</tr>
<tr>
<td>Faculty</td>
<td><a href="http://faculty.goucher.edu/username">http://faculty.goucher.edu/username</a></td>
</tr>
<tr>
<td>Staff</td>
<td><a href="http://staff.goucher.edu/username">http://staff.goucher.edu/username</a></td>
</tr>
</tbody>
</table>

4. When prompted, enter gcadmin\username and your network password, then click OK.
6 Click on the **PUBLISH** button.

<table>
<thead>
<tr>
<th>Hot Tip!</th>
<th>Use the <strong>OPTIONS</strong> button to see additional settings available</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Use the <strong>SHOW</strong> button to view pages on <strong>MEYERHOFF</strong>.</td>
</tr>
</tbody>
</table>

| CAUTION! | FrontPage web sites require special files to work properly. These files are called “FrontPage Server Extensions”. At Goucher College, a call to the Help Desk will ensure these files are available to you. However, if you are creating a web site outside of Goucher, such as through Comcast or AOL, you will need to ask about FrontPage Server Extensions. |
Selecting Pages To Publish

You may find that you only have some of your pages ready for publishing, and others that are still being edited. In this case, you can mark those that should NOT be included when you publish.

**STEPS**

1. From the *Folder List*, right-click on the file you do NOT want to publish.
2. Click on *Properties* and select the *Workgroup* tab.
3. Place a checkmark in the *Exclude this file when publishing the rest of the Web* box.
4. Click **OK**.

When you’re ready to publish that page, repeat the above steps, but clear the checkmark.
Training Exercise #2

In this exercise, you will continue editing the pages on the “Department” web site.

1. Reopen the department web located in your class files under \FrontPage 2000 Classes\Page Editing Fundamentals.

2. From the Visitors folder, open the page general.htm in Page View (page 2).

3. Create a 2-column table. In the first column place the names of people from your department and in the second column place their extensions (page 16).

4. Create a column for Room Number between Name and Extension (page 17).

5. Give this page a background color of your choice (page 14).

6. Save and close the page (page 10).

7. Publish this web to the training account assigned to you for class (page 19).

8. Test that the site has been published correctly by opening a browser and navigating to the correct web address for your site. Your home page should be displayed. Close the browser.

9. Return to Frontpage and close the department web.
Chapter Three: Web Page Graphics

In this chapter, learn how to …

- Insert a horizontal line
- Add and modify graphics
- Complete a training exercise
Inserting A Horizontal Line

To break up the text in your document and draw attention to specific information, you could add a horizontal line to the page.

**STEPS**

1. Move the insertion point (blinking line) to the beginning of the paragraph below where the line should go.
2. Click on the **Insert** menu and select **Horizontal Line**.
3. Format the line by right clicking on it and selecting **Horizontal Line Properties**.

| Hot Tip! | Although there are many free horizontal line graphics available on the web that you can download, these need to be inserted on your page using the Image button on the toolbar. |
Inserting Images

Graphics on a web page are actually contained in a separate file apart from the text itself. Although it all looks like one document when viewed from a browser, a web page is often a collection of many different files combined together into one web page.

You can get images by creating them yourself, scanning them into your computer, or buying them as part of a commercial clip art package. Picture files, which are enormous in their maiden form, must be compressed into a much smaller size for use on the Internet. Most browsers can only recognize certain types of graphic file formats. Here are the two most common formats used on the web:

- **GIF** (CompuServe Graphics Interchange Format)
  
  This format uses only 256 colors so is best used for graphics with a quality such as comics, cartoons, or backgrounds.

- **JPEG** (Joint Photographic Experts Group)
  
  This format uses millions of colors making it suitable for photograph-quality graphics.
**STEPS**

1. Place the cursor where the graphic should appear.
2. Go to the **Insert** menu and select **Picture** and **From File** (find your file and double-click on it) or **Clipart** (use the task pane to search for an appropriate picture).

| Time Saver! | If the picture file already appears in your Folder List, you can drag it onto your page. |

Keep in mind that picture files are separate from your page files. The means that one picture on a web page equals two files on your web’s folder list – one for the page and one for the picture. When you save your page, you may be prompted to also save any new or modified graphic files.
Often, an image does not appear on your web page exactly as you would like it. It may be too large or it may not be aligned to your satisfaction. In order to edit the way an image appears on the page, right-click on the picture and select **Picture Properties**. A dialog box will open allowing you to make formatting changes to the graphic.
Training Exercise #3

Continue to edit the web pages on the “Department” web site.

1. Reopen the department web located in your class files under \FrontPage 2000 Classes\Page Editing Fundamentals.

2. Open the page index.htm. Insert any clipart picture that you want (Page 27).

3. Add a horizontal line and configure it to your liking (Page 25).

4. Close and save the page, then publish your changes to the training web site assigned to you for training (page 19).

5. Close the department web.