FrontPage II: Advanced Page Editing

Center for Teaching, Learning, and Technology

Phone: 410.337.6066
E-mail: training@goucher.edu
Web: www.goucher.edu/training

Revised March 2005
# Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Special Notations and Symbols</td>
<td>iii</td>
</tr>
<tr>
<td><strong>Chapter One: Working With Frames</strong></td>
<td>1</td>
</tr>
<tr>
<td>Understanding Frames</td>
<td>2</td>
</tr>
<tr>
<td>Starting A Page With Frames</td>
<td>2</td>
</tr>
<tr>
<td>Resetting An Initial Page</td>
<td>5</td>
</tr>
<tr>
<td>Setting A Target Frame</td>
<td>6</td>
</tr>
<tr>
<td>Hiding The Frame Borders</td>
<td>7</td>
</tr>
<tr>
<td>Modifying The Frame Layout</td>
<td>7</td>
</tr>
<tr>
<td>- Splitting Frames</td>
<td>7</td>
</tr>
<tr>
<td>- Deleting Frames</td>
<td>8</td>
</tr>
<tr>
<td>- Resizing Frames</td>
<td>8</td>
</tr>
<tr>
<td>Exercise One</td>
<td>9</td>
</tr>
<tr>
<td><strong>Chapter Two: More On Graphics</strong></td>
<td>10</td>
</tr>
<tr>
<td>Blending A Graphic With The Background</td>
<td>11</td>
</tr>
<tr>
<td>Create A Link FromA Picture</td>
<td>12</td>
</tr>
<tr>
<td>Using Hotspots</td>
<td>12</td>
</tr>
<tr>
<td>Specifying An Alternative Representation</td>
<td>13</td>
</tr>
<tr>
<td>Adding A Marquee</td>
<td>15</td>
</tr>
<tr>
<td>Inserting Hover Buttons</td>
<td>16</td>
</tr>
<tr>
<td>Exercise: Two</td>
<td>18</td>
</tr>
<tr>
<td><strong>Chapter Three: Global Effects</strong></td>
<td>19</td>
</tr>
<tr>
<td>Using Themes</td>
<td>20</td>
</tr>
<tr>
<td>Creating A Shared Border</td>
<td>21</td>
</tr>
<tr>
<td>- Inserting Shared Borders</td>
<td>22</td>
</tr>
<tr>
<td>- Configuring Shared Borders</td>
<td>23</td>
</tr>
<tr>
<td>Editing Navigation Bars</td>
<td>24</td>
</tr>
<tr>
<td>Exercise Three</td>
<td>26</td>
</tr>
</tbody>
</table>
### Special Notations and Symbols

<table>
<thead>
<tr>
<th>Notation</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Keystroke</td>
<td>🔄Enter</td>
<td>Press Enter on the keyboard</td>
</tr>
<tr>
<td>Button/Mouse</td>
<td>OK</td>
<td>Click on OK in the current window</td>
</tr>
<tr>
<td>Menu Item</td>
<td><strong>Tools, Options</strong></td>
<td>Go to the Tools menu and select Options.</td>
</tr>
</tbody>
</table>

### Notation | Graphic
---|---
Time Saving Shortcut | 🕒
Hot Tip! | 🌶️
Caution! | ⚠️
Chapter One: Working With Frames

In this chapter, learn how to …

- Create a page with frames
- Add pages to a frame
- Split and delete frames
- Modify a frame
- Specify a target frame
- Complete a Training Exercise
Understanding Frames

Frames allow you to show more than one HTML document on the screen at a time by dividing the screen into “window frames”. The primary use for frames is to allow one part of the screen to stay the same, such as the links, while the main content of the page can change based on the user’s choices.

Starting A Page With Frames

To begin, you must first set up a blank page containing the “shell” of the frames. This page defines the frame format, and then other pages are linked to each frame to create the desired layout.

STEPS

1. From Page View, select New from the File menu
1. Click on the **Frames Pages** tab.
2. Select an initial layout that most closely resembles your desired look and click **OK**.
3. Link each frame to an HTML file:
   - To display an existing page inside a frame click on the **SET INITIAL PAGE** button
   - OR
   - To create a new page to be displayed in the frame, click on the **NEW PAGE** button.

---

**CAUTION!**

Be careful when saving your page. The framed page that makes up the “shell” is saved under a unique name as well as any new pages displayed inside the frames. The Preview area of the Save Window will let you know which file is currently being saved.
The preview screen will highlight the precise file being saved in this.
Resetting An Initial Page

You may find later that you want to change the initial page displayed in a frame.

**STEPS**

1. Right-click inside the desired frame and select **Frame Properties**.

2. In the space labeled **Initial Page**, either type in the new page to be displayed or use the **BROWSE** button to select it. To create a new page from scratch in this frame, delete the text completely and leave the box empty.

3. Click **OK**.
Setting A Target Frame

In most circumstances, you will want any links inside your framed page to simply refresh one of the frames already displayed. After all, that’s the purpose of using frames so that some of the information is permanent while other information changes. The frame that most often displays new information is called the Parent frame or Main frame. If you’ve used a FrontPage template to create your frames, your page is already set up to operate in this manner.

However, you may want some links to override your framed design and open without frames displayed. Or, you may want some links to open a page in a completely new browser window. In these circumstances, you need to change the Target Frame.

**STEPS**

1. Right-click on the link to be modified.
2. Select **Hyperlink Properties** from the shortcut menu displayed.
3. Click the **TARGET FRAME** button.
4. Choose the correct option from the Common Targets list.
5. Click **OK** twice to save the new setting.
Hiding The Frame Borders

By default, framed pages are viewed with the borders between each frame displayed in the browser. You may find your page looks cleaner without the borders.

**STEPS**

1. Right-click anywhere inside the framed page and select **Frame Properties**
2. Click on the **FRAMES PAGE** button
3. Select the **Frames** tab
4. Deselect the **Show Borders** option
5. Click **OK** twice to save the new setting

Modifying The Frame Layout

You can modify the layout of your frames beyond the original template used to create the page by splitting frames to create new ones or deleting frames currently displayed.

**Splitting Frames**

**STEPS**

1. Click inside the desired frame to select it.
2. Select **Split Frame** from the **Frames** menu.
Choose to either split the current frame horizontally or vertically.

Click OK.

Follow the steps on page 6 to set the contents for the new frame.

**Deleting Frames**

**STEPS**

1. Click inside the desired frame to select it.
2. Select **Delete Frame** from the **Frames** menu.
3. Click **OK**.

**Resizing Frames**

**STEPS**

1. Click inside a frame to select it.
2. Move the cursor to one of the frame borders until it changes to a double-sided arrow \( \leftrightarrow \).
3. Drag the mouse to resize the frame border.
Exercise One

Continue working with the “Advanced Editing” web to create and modify a new page containing frames. (The “Advanced Editing” web is located in your Class Files under the FrontPage Classes/3-Adv Editing folders.)

1. Create a new framed page using the ‘Contents’ template (Page 2).

2. Link the left frame to the Organized.htm page and resize the frame so there is not bottom scrollbar displayed (Page 6).

3. Link the right frame to the Schedule.htm page (Page 6).

4. On second thought, split the left frame into two rows (Page 7) and display the Organized.htm page on the bottom (Page 6) and the Logo_page.htm page on the top (Page 6). Resize the frames as you see fit.

5. Using the Frame Properties, turn off the scrollbar for the top-left frame and turn off the frame borders (Page 7).

6. Test your new page using the Preview tab.

7. Return to Normal View and save your new framed page as Schedframe.htm.
Chapter Two: More On Graphics

In this chapter, learn how to …

- Blend a picture into the background
- Create a link from a picture
- Set an image hotspot
- Specify an alternative representation for an image
- Add a Marquee
- Insert Hover Buttons
- Complete a Training Exercise
Blending A Graphic With The Background

When you first insert a graphic onto a web page, it may not blend in with the page background very well. A white or black edge around the picture may show up that disrupts the effect you want to create. In this circumstance, you can often blend the picture into the background by making a specific color in the picture transparent.

**STEPS**

1. Select the picture to be blended with the page background.

2. From the Pictures toolbar, click on the Set Transparent Color button.

   ![Hot Tip!]

   If the *Pictures* toolbar is not visible, use the *Toolbar* command from the *View* menu to display it.

3. Point to the picture and click on the color you wish to be erased. (Usually this is the white or black background of the picture.)
Create A Link From A Picture

Text isn’t the only basis for links anymore. Using pictures or graphics as links can make your page interesting and fun!

**STEPS**

1. Select the picture or graphic to be used as a link.
2. Click the **HYPERLINK** button on the toolbar.
3. Enter the link information in the dialog box that appears.
4. Click **OK**.

Using Hotspots

You can also create multiple links from a single picture. For example, you can take a map and divide it up to create multiple links based on locations. You do this by creating hotspots. When a user’s mouse clicks anywhere inside a hotspot, the specific hyperlink for that hotspot is activated.

**STEPS**

1. Select the picture or graphic to be divided into multiple hotspots.
2. Using the Picture toolbar, click on one of the **HOTSPOT** buttons on the toolbar. Choose the button that corresponds to the shape of the hotspot you wish to draw.
3 Your cursor will change to a pencil when moved above the picture. If using the rectangular or oval shaped tool, click and drag across the picture to create a hotspot. If using the polygonal shaped tool, a line will be drawn each time you point and click. Double-click to complete the shape.

| CAUTION! | You can not extend the hotspot shape beyond the picture border. |

4 When the shape is complete, the Create Hyperlink dialog box opens. Enter the desired link information and click OK.

| Hot Tip! | To more easily see where your hotspots are located, use the Highlight Hotspots button Error! Objects cannot be created from editing field codes on the picture toolbar. Click again to turn off this feature. |

Specifying An Alternative Representation

There are times when pictures and graphics are not seen by the user. Either they have configured their browser to not load pictures in order to save time, or they are viewing a text-only version of your page. Pictures also take time to load. For these reasons, you can have a text description or low resolution of your picture appear either in place of the picture or just until the picture loads. This is called an Alternative Representation.
STEPS

1. Right-click on the picture to be modified and choose **Picture Properties**.
2. If necessary, click on the **General** tab.
3. To set a text alternative, type in the text to be displayed in the **Text** option under **Alternative representations**.

   ![Alternative representation table]

4. If desired, use the **BROWSE** button to select a lower resolution version of the picture to load on older browsers.
5. Click the **OK** button.
6. Test the changes by turning off images on your browser and then selecting Preview in Browser from the File menu.

**Hot Tip!**

Although browsers vary between types and versions, most browsers are a version of either **Internet Explorer** or **Netscape**. You will probably be able to turn off images in Internet Explorer by selecting **Internet Options** from the **Tools** menu. In Netscape, try choosing **Preferences** from the **Edit** menu.
Adding A Marquee

A Marquee appears as text scrolling across the screen.

CAUTION!
Will not Work in Netscape browser!

STEP

1. Open the page where the marquee should be included.
2. Place the cursor on the page where the marquee should appear to the user.
3. Use the Insert menu to select Component, and then Marquee.
4. Type in the text to appear and set any other options necessary for the effect you want to create.

6. Click OK.

CAUTION!
Will not Work in Netscape browser!
Preview the results using the Preview Tab. To edit, return to the Normal Tab and double-click on the marquee to make changes.

Inserting Hover Buttons

Hover buttons are linked buttons that change in some way when the mouse is moved over top of them. This can create an animated and interactive effect for your site.

STEPS

1. Open the page to be modified.
2. Place the cursor where a button should appear.
3. Use the Insert menu to select Component, and then HOVER Button.
4. Insert the text to appear inside the button. If necessary, use the FONT button to modify the appearance of the text.

![Hover Button Properties](image)
6 Use the **BROWSE** button to establish a hyperlink for the button when it is pressed by the user.

6 Change any other formatting options as desired and click **OK**.
Exercise Two

Continue using the “Advanced Editing” web to modify images and create graphical links.

1. Open the “Clock_Main_Frame” page.
2. Blend the images on the Navigation Bar into the background (Page 11).
3. Link the pictures on the Navigation Bar using the following guide: (Page 12)
   
   Time Management to Clock_Time.htm
   Impact of the Web to Clock_Impact.htm
   Email Etiquette to Clock_Email.htm
   Sharing Information to Clock_Sharing.htm

4. Create hotspots on the clock that also link to the pages above using the time that each seminar is being offered (Page 12).

   Time Management 9am-10am
   Impact of the Web 10am-11pm
   Email Etiquette 1pm-2pm
   Sharing Information 2pm-3pm

5. Insert a marquee somewhere on the page stating “Register Now at 410-830-5500!” Configure it to your liking (Page 15).

6. Create at least two hover buttons from the course titles leading to the seminar descriptions (Page 16). Configure these to your liking as well.

7. Save your changes, then test the links using the Preview tab.
Chapter Three: Global Effects

In this chapter, learn how to …

- Apply a Theme
- Create and Configure Shared Borders
- Complete a Training Exercise
Using Themes

Themes are a quick and convenient way to spruce up all the pages on your site with similar background images, fonts, colors, bullets, etc.

STEPS

1. Click on the **Format** menu and select **Themes**.
2. Click on any of the Themes listed to see a preview on the right. Changing any of the options listed will also update the preview to show the impact of the changes.

3. At the top left, choose to either apply the changes to the selected page only (if applicable) or to all the pages.
4. Click **OK** to apply the selected changes to your site.
Creating A Shared Border

Like a frame, a *Shared Border* splits a page into multiple sections, and allows these sections to remain the same for multiple pages on the site. Unlike a frame, a Shared Border is not a collection of numerous pages viewed together as a single page. Instead, it is more like using an automatically formatted table to divide the page into different portions.
Inserting Shared Borders

First, you will have to tell FrontPage to insert the sections where Shared Borders are going to be used

**STEPS**

1. Open the web or page you want to add shared borders to.
2. Select the **Format** menu, and then **Shared Borders**.

   ![Shared Borders dialog box]

3. Choose whether you want to apply shared borders to all the pages in the web or just to the current page.
4. Use the checkboxes to indicate where you want the borders to appear, and if you want navigation buttons to appear.
5. Click **OK**
Example of page immediately after shared borders are inserted to the top and left:

---

Configuring Shared Borders

Next, you will have to configure those sections to your liking.

### STEPS

1. Open a page containing a shared border.
2. Replace any comments with a Page Banner by selecting the border, then choosing **Page Banner** from the **Insert** menu. Once you insert the first banner, all pages in your web with shared borders will also include a banner with the page title as the default text. If a theme is applied to the page, you will have the choice including any text in a picture border.
Right-click on any navigation bars and select **Navigation Bar Properties**.

**Navigation Bar Properties**

- **Hypelinks to add to page**:
  - Parent level
  - Same level
  - Back and next
  - Child level
  - Top level
  - Child pages under Home

- **Additional pages**:
  - Home page
  - Parent page

- **Page navigation bars will appear on**
- **Pages navigation bars will link to**
- **Home page**
- **Other pages**

**Orientation and appearance**

- **Horizontal**
- **Vertical**
- **Buttons**
- **Text**

Select the appropriate options and click **OK**.

Repeat these steps for each page in the site with shared borders.

**Editing Navigation Bars**

If you choose to use Navigation Bars with your shared borders, then you need to use the Navigation View to set up the navigational structure of your web. This structure will then automatically update the Navigation Bar in your shared borders.

**STEPS**

1. Select the **NAVIGATION** view from the View Bar.

---

24 Front Page 3: Advance Page Editing
2. Click and drag a web page from the Folder List to the Navigation View. Release the mouse when you see a line connecting it to the correct page.

3. Continue with step 2 until you have replicated your web site layout.

Example of a completed navigational structure in Navigation View

If you would like to change the text on a button, click once on the title in the navigation square and retype the name when the blinking cursor appears. This will also rename the page title in Folder View.
**Exercise Three**

Repeat the steps covered in Lesson 3 to create new effects in the Conference web site...

1. Open the “Exercise 3” web located in your Class Files in the FrontPage Classes/3-Adv Editing folders.

2. Apply a theme of your choice to the entire web (Page 20).

3. Apply a top and left border to all the pages on the web (Page 21).

4. Set up the navigational structure of the web in Navigation View (Page 24).

5. Open the Welcome.html page. Configure the Navigation Bar properties and insert a page banner. Save the changes.

6. Open the Schedule.htm page and insert a marquee somewhere on the page stating “Register Now at 410-337-6066!” . Configure it to your liking (Page 15).

7. Create at least two hover buttons on the Schedule.htm page leading to the seminar descriptions (Page 16). Configure these to your liking as well.

8. Save your changes and test the page using the Preview tab.